
Sac City Instructional Development   

Turn Class Rosters into Excel Gradebooks  
Version 9.0 – Fall 2007 (Student Learning Outcomes worksheet added) 

Getting started 
• Access the handouts and gradebook start file at http://web.scc.losrios.edu/instrdev/  
• Sign-in for Flex Credit using the sign-in sheet 
• Prepare computer workspace  

o Browser (Firefox or Internet Explorer), two windows open 
o Spreadsheet (Microsoft Excel) 
o Quick switch between open windows (PC: ALT +Tab or Mac: CMD + Tab) 
o Excel Toolbars: Standard, Formatting with formula bar should be visible 

• SLO web site: http://web.scc.losrios.edu/slo  

Who should attend 
Faculty interested in using Excel (or a spreadsheet application) to prepare class rosters for tracking 
attendance, assignments AND calculating in-progress and final grades. A new worksheet was added to 
record your assignments and class averages when sharing student learning outcomes.  

Skill level 
Novice; Intermediate 

Workshop structure 
• Inquire: Grading structure used now, Excel familiarization … 
• Tour Sample 
• Demonstrate Gradebook features 
• Highlight seven stages of completion 
• Question and Answer anytime 
• Complete flex workshop feedback form (on paper) 

Introductions 
• Presenter – Melissa Green, Instructional Development Coordinator 
• Participants – Excel experience?  Gradebook software used?  

Types of assignments used in courses? Total points or weighted calculations?  
Use Tables in word processing documents?  
Socrates users, familiar with curriculum forms and student learning outcomes 

Featured software tips 
• Open multiple working windows (Excel and Internet Explorer) 
• Type in cells of worksheet (notice typing is automatically displayed in other cells!) 
• Select, copy and paste  
• Set print area (File > Print Area > Set Print Area) 
• Filenames: section number, class name  
• Keyboard shortcuts for menus & dialog boxes 

o Save (PC: CNTRL + s, Mac: CMD + s) 
• Modifier keys: CNTL, ALT/Option, CMD, Shift, Tab, Enter 
• Read/search  Excel’s online help resource 

 

Keep your gradebook information secure. Limit exposure to this file or printed copies by others 
people. Always keep a current printed copy and shred past copies of your gradebook printouts.  
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Tour a finished project 
Worksheets Attendance page Zoom views Marking assignments as 

fitting SLO criteria 

Spreadsheet basics (fill-in the blanks from supplied terms) 
• Columns, rows, cells (stretch column width like rubberbands)  
• Cell Ranges 
• Tabs (for each Worksheets)  
• Scroll bars (horizontally and vertically)  
• Status Bar 

 

 
 
 
 

• Zoom view  
• Print Area (not shown) 
• Toolbar(s) (grayed commands) 
• Formula Bar  
• Active Cell  
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Demonstration 
• Download the single Gradebook file (multiple attendance patterns included) 
• Download and open a roster file from http://inside.losrios.edu  

o Select columns of student id numbers and names, copy names 
• Return to/Open the gradebook spreadsheet  

o Open to the Course Info tab 
o Paste to Course Info worksheet (shows on Attendance, Course Summary …) 
o Save (I list this once, but save often!) 

• In OGS go to SOCRATES and locate course outline 
o Copy Student Learning Outcomes from SOCRATES 
o Paste to the SLOs worksheet 
o Add a homework assignment 
o Add a quiz 
o Add a lab assignment 
o Review SLOs worksheet & Class Summary 

• More Excel tips 
o Change zoom view 
o Emphasize the names print on each page (Page Setup options) 
o Set Attendance pattern for this semester 

• Printing 
o Select area to print, File > Print Area > Set Print Area 
o File > Page Setup 
o File > Print Preview 

• Logon to Exchange via Outlook Web Access 
o Create a new message to yourself 
o Attach the new gradesheet document 
o Send message with attached Gradebook  

Stage 1 

Preparation: 
Download a gradebook file from http://web.scc.losrios.edu/instrdev/. Save the gradebook based on 
the course and section number, i.e., bus210-07345.xls 

Goal:  
Familiarize yourself with the SCC Gradebook file and customize it for your class(es) 

Steps:  
1. Open a copy of the gradebook spreadsheet  
2. Tour the worksheets 
3. Note instructions on SCC Gradebook worksheet (worksheets are “protected”) 
4. View Class Summary worksheet  
5. Change zoom view of worksheets 
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Protected worksheets  
All worksheets have been protected using the Tools menu but no password has been used. If you need 
to edit a worksheet follow safe computing practice: 1) save a copy of the file, 2) work on the copy of 
the file, 3) use the Tools > Protection > Unprotect Worksheet command. Make your edits. Reprotect 
the worksheet Tools > Protection > Protect Worksheet … a password is optional. (Don’t use a 
password if you might forget it.)  
 
Customize the Course Info worksheet  

 
1. Use the tabs to return to the Course Info worksheet 
2. Edit the gray boxes in B3 to B6 and D3 to D6 
3. This information is shared to other worksheets 

 

 
 

Student information will be copied from the roster and pasted beginning at A9. The student 
information is also shared to other worksheets.  

Review:  
When in doubt, open the Excel Online Help wizard. Search online help and Microsoft’s web site.  
Step back from a detailed workbook by changing the zoom view. (Use this feature often!) 

Stage 2 

Goal:   
Access class roster via Intranet logon, copy student info to Gradebook . 

Steps:  
At the desktop, create a new folder, use your last name as the folder name 
Open Internet Explorer, go to https://inside.losrios.edu  
Logon using your email account name and Intranet password  
Open a class roster, go to the Download Roster page  
Download the Excel version of your class roster to the new folder on the desktop  
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Password Review:  
Your email/network login, Blackboard and Intranet passwords will be different unless you change 
them to match!  
 
The LRCCD password policy has changed. A "passphrase" of 10 characters, with at least one capital 
and one lower-case letter is required. If you forget your passphrase, the  http://ex.scc.losrios.edu site 
has a password reset link (enter d-o-b, last four of ssn and full email address). Remember passwords 
are case-sensitive and if you get an error, check the position of the Caps Lock key. In a public 
computer lab, always use the Log Off option and close the browser window when you have accessed 
a site requiring a user logon.  

Stage 3 

Goal:  
Adjust the spreadsheet column widths to prepare names for the copy and paste step. Use the keyboard 
to control the selection of information.  

Practice:  
• Click the mouse in cell A5 to set the cursor there 
• Press Tab key to move the cursor right to cell B5 
• Move the cursor down with Enter key, what is your location? ______ 
• Move the mouse to the top of the active window; position the cursor over the line inbetween 

columns A and B, notice the two-pointed cursor 
• Drag the line to the right to widen the column (to the left to reduce the column width) 
• Set the cursor in cell A5, hold the Shift key and click on the name at then bottom of your list 

to select everything inbetween the first and second clicks.  

Steps:  
1. Open the default roster  
2. Widen columns (A, B, C) to see id numbers and names 
3. Select id numbers and names across two columns 
4. Edit > Copy 

 

Review:  
Text in a cell can spread outside cell borders (unless numbers or letters are in adjacent cell) and 
selecting the cell selects all the information in a cell regardless of the column width 
 
Keyboard shortcut for copy (PC: CNTR + c, Mac: CMD + c) 
Keyboard shortcut for paste (PC: CNTR + v, Mac: CMD + v) 
Click then Shift + Click to select everything inbetween (works top to bottom in a text document, 
and/or left to right in a spreadsheet) 
 
Step back from a detailed workbook by changing the zoom view. 
Set the Print Area to control how much of your worksheet is printed 
Use Print Preview to check print output before printing. 
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Stage 4 

Goal:  
Add the Student Learning Outcomes from SOCRATES to the SLOs worksheet.  

Steps:  
• From the OGS home (https://inside.losrios.edu) go to SOCRATES 
• Search for your course outline 
• Scroll through the course outline to the Student Learning Outcomes section 
• Copy the list of SLOs in the browser window 
• Go back to your gradebook, go to the SLOs worksheet  
• Click cell B9 and choose Edit > Paste 
• The list is now embedded in your gradebook 
• Update the year SLOs were copied from Socrates in cell C8 
• Press Tab key to move the cursor right to cell B5 
• Move the cursor down with Enter key, what is your location? ______ 
• The first 10 assignments from other worksheets are automatically displayed on the SLO 

worksheet along with the class averages on those assignments. 
• Mark an "X" where a graded activity meets the learning outcome. The E column reflects the 

number of Xs in each row. 
• Confirm the Print Area of this worksheet and print to share will colleagues 

 

 
 

Review:  
• SLO web site: http://web.scc.losrios.edu/slo  

 
Watch for opportunities to discuss learning outcomes with your colleagues.  Visit the SLO web site for 
current  information.  
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Stage 5 

Goal:  
 Customize the Attendance worksheet for this semester. 

Steps:   
Click on the Attend tab to view this worksheet.  
Confirm the date of the first Monday of the semester is typed in cell C1 
To open up the attendance pattern you need, select the two columns, beginning with the desired 
pattern (MTWT, MW, TuTh, 1-day) and the column to the right of it 
Format > Column > Unhide will reveal the hidden dates 
 

 

Review:  
By including all attendance patterns on one spreadsheet it is easy to adapt from one attendance pattern 
to others while preserving the homework, quiz, lab and summary details.  

Stage 6 

Goal:  
Review the average scores for graded activities as  reported on the Summary and SLO worksheets. 
Use the AutoFilter feature to show above or below averages.  
 
Class Average  =AVERAGE(K10:K159) is the basic formula, but I’ve customized it to not report 0 
so the printed worksheet looks nice - =IF(K7=""," ",AVERAGE(K10:K159)). With this IF statement 
when no assigned points are entered, the value will appear as a blank and if points are entered then the 
formula calculates.    
 
The trick with AVERAGE is that empty cells do not count in the calculation. This is a good thing! 
With 150 possible students on your gradebook roster, we do not want empty cells counted. So if an 
active student does not submit an assignment, then enter 0 for their points (zero). This will count their 
score and include them in the calculation.    
 
The Class Average row has AUTOFILTER turned on. You can use this Excel feature to identify the 
students who are struggling with graded assignments on the Class Summary, Homework, Lab and 
Quiz worksheets. (AutoFilter is also how you hide students who have dropped your class. On the 
Course Info worksheet, delete the number in the D column next to the name.) 
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AutoFilter Steps:  

Review:  
AutoFilter is a wonderful feature that I use in my everyday use of Excel. There are many options to 
explore when using a Custom Filter and combined filters. 

Stage 7 

Goal:  
Paste names from roster to gradebook file and prepare for printing 

Steps:  
The Clipboard holds text or graphics that you copy or cut 
Open your gradebook spreadsheet by using the Window menu (or Alt + Tab) 
Click on the Course Info worksheet 
Click in cell C9 to set the cursor there 
Edit > Paste Special (optional  variation on Paste - “values” preserves existing formatting) 
Confirm student information is shared on other worksheets 
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Return to Course Info worksheet 
Use File > Print Preview to view the worksheet, close or cancel to return to the worksheet 
Use File > Page Setup to view the options for printing this worksheet  

• Landscape or portrait orientation 
• Gridlines 
• Custom Header/Footer (date, page) 
• Confirm Repeating Rows and Columns (set in this template) 

 
Prepare for printing 

• Go to the Attendance worksheet and reduce the page view with the Zoom options until you 
see  all your student names.  

• Select the print area by dragging from the bottom right cell to the top-left cell (A1) because 
the mouse will stop at A1 

• Set this selection as your Print Area (File > Print Area > Set Print Area)  
• Confirm with File > Print Preview (use the Next button to see additional pages) 
• Confirm the names or dates (rows or columns) print on multiple pages 
• Set the Print Area for each worksheet you want to print 
• Save (often!) 

Review:  
Set the Print Area before printing – Always!  
Use Print Preview to test you page printing – Always!  
Set the Print Area for each worksheet – Always!  
 

Keep your gradebook information secure. Limit exposure to this file or printed copies by others 
people. Always keep a current printed copy and shred past copies of your gradebook printouts.  
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Before you go 

Goal:  
 Email copy of the workshop gradebook file to yourself from the lab today. 

Steps:  
Open a web browser and go to http://ex.scc.losrios.edu
Log on with your name and password 
Create a new message 
Type your name in the To field (NOT your email address) 
Click on the icon with a face and checkmark (this will look up your email address) 
Click on the Attachments tab 
Browse to the gradebook file on the hard drive and click OK 
Click the Add Attachment button 
Click the Send Message icon 
Click the Log off button 
Close Internet Explorer 

Review:  
Any web connected computer can be used to send or read your SCC email. 
Type a colleague’s name in the To field, don’t try to remember the email address. Let the server look 
up the correct address.  
Add documents or images as attachments. Small files are better than large ones. Keep it under 250K. 
Use the Log off button when reading SCC email from a public computer lab. 

Murphy's Law 
"If things can go wrong, they will go wrong." Spreadsheet formulas are easy to delete. Formulas also refer 
to specific cell or ranges and if you add columns/rows or delete them, check your formulas for errors. 
Always use a hard copy to keep a record of your grades and then enter scores into an electronic 
spreadsheet. Add a few random scores on paper to make sure you get the same results in the electronic 
version.  

Web resources 
University of Texas, Academic Computing and Instructional Technology Services 
http://www.utexas.edu/cc/training/handouts/excelgrade     
 
Old Dominion University 
http://web.odu.edu/webroot/instr/ED/llschult.nsf/pages/excel_gradesheet  
 
Microsoft 
http://www.microsoft.com/education/?ID=ManagingGrades  
 

Shortcuts - Review 
Keyboard shortcuts 

Copy (PC: CNTR + c, Mac: CMD + c) 
Paste (PC: CNTR + v, Mac: CMD + v) 
Tab moves cursor to next cell 
Shift+Tab moves cursor to previous cell  
Return/Enter moves cursor down one cell 
Click a cell, scroll down/up, Shift+Click to select a range of cells 
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Formulas in use 
Course Summary worksheet – a handy reference if you are planning your own spreadsheets.  
 
=SUM(E7:R7) Adds a range of values (a row or column) 
='Course Info'!B9 Displays value from cell on another worksheet 
=IF(Attend!BJ9=0," ",Attend!BJ9) 
=IF(Homework!BC9=0," ",Homework!BC9) 
=IF(Lab!AI9=0," ",Lab!AI9) 
=IF(Quiz!W9=0," ",Quiz!W9) 

Displays a space instead of 0 in an empty cell and 
reports a value from another worksheet 

=IF(totalpoints=0," ",SUM(E9:R9)) Displays a space or adds a range of values 
=IF(totalpoints=0," ",S9/$T$7*100) Displays a space or shows a percent value 
=IF(totalpoints=0," ",VLOOKUP(T9,$X$2:$Z$7,2)) Displays a space or looks up a value and shows its 

corresponding letter grade 
 
Attendance worksheet 
Cell C9 [8/18/2007] =C9+7 Looks at a date in C9 and adds 7 to it. Copy this 

formula across the column by dragging the lower 
right corner of the C10 Cell  (following this 
example). 

 

Notes 
The worksheets are protected. There is no password required to unlock each sheet to make your custom 
edits to the formulas. I recommend re-protecting the worksheets to minimize your unintentional edits.  
 
My suggested method of hiding students who have dropped is to use the Auto Filter options in Excel. On 
the Course Info sheet is the following tip:  

1. Do not delete students from this sheet 
2. Delete number in C column if student has dropped 
3. Invoke custom Autofilter on each sheet to hide "0" entries in the Student ID column 

 
Once you have created a spreadsheet to meet your grading needs, clear out the student information on a 
fresh copy of the file for next semester. Highlight all the scores and choose Edit > Clear > Contents. Edit 
the start dates of the semester on the attendance sheets, and delete the student names from the Course Info 
worksheet. Save the file again. After you have added a new semester’s roster, be sure to set the print area 
for this Gradebook.  
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